[packages] add ap51-flash
[openwrt/svn-archive/archive.git] / libs / librsync / Makefile
index 2b1142f6f561b31db26b02eadad6e36b1c2694a6..677d249044f5faac36359b0908ee92bf65ee3fc0 100644 (file)
@@ -1,36 +1,34 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5329 2006-10-28 22:43:08Z nico $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=librsync
 PKG_VERSION:=0.9.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/librsync
 PKG_MD5SUM:=24cdb6b78f45e0e83766903fd4f6bc84
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/librsync
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=librsync implements the rolling-checksum algorithm of remote file synchronization
-  DESCRIPTION:=\
-       librsync implements the rolling-checksum algorithm of remote file\\\
-       synchronization that was popularized by the rsync utility and is\\\
-       used in rproxy. This algorithm transfers the differences between 2\\\
-       files without needing both files on the same system.
+  TITLE:=implementation of the rolling-checksum algorithm
+  URL:=http://librsync.sourceforge.net/
+endef
+
+define Package/librsync/description
+       librsync implements the rolling-checksum algorithm of remote file
+       synchronization that was popularized by the rsync utility and is
+       used in rproxy. This algorithm transfers the differences between 2
+       files without needing both files on the same system.
 endef
 
 define Build/Configure
@@ -40,6 +38,8 @@ define Build/Configure
        );
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -47,20 +47,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/librsync{,-config}.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/librsync{,-config}.h \
-               $(STAGING_DIR)/usr/lib/librsync.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/librsync{,-config}.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/librsync/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.so.* $(1)/usr/lib/
 endef