[packages] add ap51-flash
[openwrt/svn-archive/archive.git] / libs / librsync / Makefile
index dc8f1a81b1b7270fa1f31d44098daaf2147258cf..677d249044f5faac36359b0908ee92bf65ee3fc0 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=librsync
 PKG_VERSION:=0.9.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/librsync
@@ -22,6 +21,7 @@ define Package/librsync
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=implementation of the rolling-checksum algorithm
+  URL:=http://librsync.sourceforge.net/
 endef
 
 define Package/librsync/description
@@ -47,9 +47,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/librsync{,-config}.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.{a,so*} $(1)/usr/lib/
 endef