[packages] net-snmp: Enable ipv6 support if defined globally
[openwrt/svn-archive/archive.git] / libs / libsamplerate / Makefile
index dd3cb36d91ee0e347451cddc8a1b22554e83cefc..ea877350bbb32b19b88832835edfa41a4305aa4b 100644 (file)
@@ -1,23 +1,19 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $ Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsamplerate
-PKG_VERSION:=0.1.2
-PKG_RELEASE:=1
+PKG_VERSION:=0.1.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.mega-nerd.com/SRC/
-PKG_MD5SUM:=6861c2c6b8e5273c9b80cf736b9fd0e
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=3f91af22a6c4135485594d0d2c91d45d
 
 PKG_FIXUP = libtool
 
@@ -32,30 +28,29 @@ define Package/libsamplerate
 endef
 
 define Package/libsamplerate/description
-       Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio
+ Secret Rabbit Code (aka libsamplerate) is a Sample Rate
+ Converter for audio.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-fftw \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --disable-fftw \
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Build/InstallDev
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 define Package/libsamplerate/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsamplerate))