[packages] Fix/Cleanup libsdl-mixer
[openwrt/svn-archive/archive.git] / libs / libsdl_mixer / Makefile
index cc28b51c131d67e1d80b527df6c7c3d2b99c331c..25e13e068943253cf778eb537a8a82bffd5194bd 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,14 +7,16 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=libsdl-mixer
+PKG_NAME:=SDL_mixer
 PKG_VERSION:=1.2.11
 PKG_RELEASE:=1
 
-PKG_SOURCE:=SDL_mixer-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.libsdl.org/projects/SDL_mixer/release/
 PKG_MD5SUM:=65ada3d997fe85109191a5fb083f248c
-PKG_BUILD_DIR:=$(BUILD_DIR)/SDL_mixer-$(PKG_VERSION)
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,39 +25,44 @@ define Package/libsdl-mixer
   CATEGORY:=Libraries
   TITLE:=Simple DirectMedia Layer Sound Mixer
   URL:=http://www.libsdl.org/projects/SDL_mixer/
-  DEPENDS:=+libsdl +libmikmod
+  DEPENDS:=+libsdl +libmikmod +libvorbisidec
 endef
 
 define Package/libsdl-mixer/description
   SDL_mixer is a sample multi-channel audio mixer library.
 endef
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
-
-CONFIGURE_ARGS += \
-       --with-sdl-exec-prefix=$(PKG_BUILD_DIR)
-
 define Build/Configure
-       $(INSTALL_DIR) $(PKG_BUILD_DIR)/bin
-       $(INSTALL_BIN) ./files/sdl-config $(PKG_BUILD_DIR)/bin/
-       $(call Build/Configure/Default)
-endef
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Configure/Default, \
+               --disable-sdltest \
+               --enable-music-cmd \
+               --enable-music-wave \
+               --enable-music-mod \
+               --enable-music-mod-shared \
+               --enable-music-midi \
+               --disable-music-ogg \
+               --enable-music-ogg-tremor \
+               --enable-music-ogg-shared \
+               --disable-music-flac \
+               --enable-music-flag-shared \
+               --disable-music-mp3 \
+               --enable-music-mp3-shared \
+               --disable-smpegtest \
+               --disable-music-mp3-mad-gpl \
+       )
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib/pkgconfig
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/SDL/SDL_mixer.h \
                $(1)/usr/include/SDL/
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libSDL_mixer*.{a,so*} \
+               $(PKG_INSTALL_DIR)/usr/lib/libSDL_mixer*.{a,la,so*} \
                $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libsdl-mixer/install