Cleanup libnetfilter-queue Makefile.
[openwrt/svn-archive/archive.git] / libs / libshout / Makefile
index 895b750aae8e954fbb774631d9ce363efc2f75c8..285f3a827c375af166c2ea19d476165e3556fa51 100644 (file)
@@ -38,13 +38,15 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               VORBIS_CFLAGS="$(STAGING_DIR)/usr/include/tremor"\
-               VORBIS_LIBS="$(STAGING_DIR)/usr/lib" \
+               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
+               VORBIS_LIBS="-L$(STAGING_DIR)/usr/lib" \
                --enable-shared \
                --enable-static \
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \