[packages] libshout: fix linking
[openwrt/svn-archive/archive.git] / libs / libshout / Makefile
index 142f2d96a5bef492ffa17e92cc78a82807dc6d4b..b7ef92ec88ea8242eba8d864ebee991075d0e960 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,22 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libshout
 PKG_VERSION:=2.2.2
 
 PKG_NAME:=libshout
 PKG_VERSION:=2.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
 PKG_MD5SUM:=4f75fc9901c724b712c371c9a1e782d3
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
 PKG_MD5SUM:=4f75fc9901c724b712c371c9a1e782d3
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 define Package/libshout
   SECTION:=libs
 define Package/libshout
   SECTION:=libs
-  DEPENDS:=+libvorbisidec
+  DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec
   CATEGORY:=Libraries
   TITLE:=Library which can be used to write a source client like ices
   URL:=http://www.icecast.org/download.php
   CATEGORY:=Libraries
   TITLE:=Library which can be used to write a source client like ices
   URL:=http://www.icecast.org/download.php
@@ -37,27 +40,21 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
-               VORBIS_LIBS="$(TARGET_LDFLAGS)" \
+               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
+               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
                --enable-shared \
                --enable-static \
        )
 endef
 
                --enable-shared \
                --enable-static \
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/shout
+       $(INSTALL_DIR) $(1)/usr/include/shout
        $(CP) $(PKG_INSTALL_DIR)/usr/include/shout/shout.h $(1)/usr/include/shout
        $(CP) $(PKG_INSTALL_DIR)/usr/include/shout/shout.h $(1)/usr/include/shout
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(SED) 's|/usr/include|$(STAGING_DIR)/usr/include|' \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/             
 endef
 
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/             
 endef