[package] update libsigc++ to 2.2.3, do not build docs and tests
[openwrt/svn-archive/archive.git] / libs / libsigc++ / Makefile
index 89ad6a81580c68c98e8e693902fae277c8181de5..90443bc9c04031810bc40f5e94da1dad79f634db 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,35 +9,43 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
-PKG_VERSION:=2.0.17
+PKG_VERSION:=2.2.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/
-PKG_MD5SUM:=fde0ee69e3125e982746d9fe005763e1
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/
+PKG_MD5SUM:=f4574b343eebc4bff66a9e1e5ce6e490
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libsigcxx
-  NAME:=libsigc++
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=typesafe callback system for standard C++
-  DESCRIPTION:=\
-       It allows you to define signals and to connect those signals to any \\\
-       callback function, either global or a member function, regardless of \\\
-       whether it is static or virtual.
-  URL:=http://libsigc++.sourceforge.net
+  URL:=http://libsigc++.sourceforge.net/
+  DEPENDS:=+uclibcxx
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
+define Package/libsigcxx/description
+ It allows you to define signals and to connect those signals to any 
+ callback function, either global or a member function, regardless of 
+ whether it is static or virtual.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
+CONFIGURE_VARS += \
+       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
+       LDFLAGS="$$$$LDFLAGS" \
+       LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -45,24 +53,19 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/sigc++-2.0 \
-               $(STAGING_DIR)/usr/lib/libsigc-2.0.* \
-               $(STAGING_DIR)/usr/lib/sigc++-2.0 \
-               $(STAGING_DIR)/usr/lib/pkgconfig/sigc++-2.0.pc
-               
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/sigc++-2.0 $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sigc++-2.0.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libsigcxx/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.* $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/sigc++-2.0 $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsigcxx))
+