dbus: moved to github
[openwrt/svn-archive/archive.git] / libs / libsigc++ / Makefile
index 72a65487013161821f4740c59f4ed7caddc2dde3..c8a87dd8d4aacb746e3b2af064a20b35771226bf 100644 (file)
@@ -1,71 +1,56 @@
-# 
-# Copyright (C) 2006,2007 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
-PKG_VERSION:=2.0.17
+PKG_VERSION:=2.2.10
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/
-PKG_MD5SUM:=fde0ee69e3125e982746d9fe005763e1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNOME/libsigc++/2.2
+PKG_MD5SUM:=73419b477f3bb9ddb9905c88a92f4b4c
 
-PKG_BUILD_DEPENDS:=libtool
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libsigcxx
-  NAME:=libsigc++
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=typesafe callback system for standard C++
-  URL:=http://libsigc++.sourceforge.net/
-  DEPENDS:=+uclibcxx
+  URL:=http://libsigc.sourceforge.net/
+  DEPENDS:=+libstdcpp
 endef
 
 define Package/libsigcxx/description
- It allows you to define signals and to connect those signals to any 
- callback function, either global or a member function, regardless of 
+ It allows you to define signals and to connect those signals to any
+ callback function, either global or a member function, regardless of
  whether it is static or virtual.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
+TARGET_CPPFLAGS +=  \
+       -fno-strict-aliasing -fno-inline \
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
-
-define Build/Configure
-       $(call Build/Configure/Default,)
-       $(call libtool_disable_rpath)
-       $(SED) 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec="$(STAGING_DIR)/usr/lib"|g' \
-               $(PKG_BUILD_DIR)/libtool
-       $(SED) 's|^postdeps=.*|postdeps=|g' $(PKG_BUILD_DIR)/libtool
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sigc++-2.0 $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sigc++-2.0.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/sigc++-2.0.pc
 endef
 
 define Package/libsigcxx/install
@@ -74,4 +59,3 @@ define Package/libsigcxx/install
 endef
 
 $(eval $(call BuildPackage,libsigcxx))
-