alsa-lib: add missing dependencies
[openwrt/svn-archive/archive.git] / libs / libsigc++ / Makefile
index 9e5d134bd6baede3e4c28bb36840ea68339611d7..c8a87dd8d4aacb746e3b2af064a20b35771226bf 100644 (file)
@@ -1,22 +1,22 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
-PKG_VERSION:=2.0.18
+PKG_VERSION:=2.2.10
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/
-PKG_MD5SUM:=ddebf5aafc8525d10366a8724abc9f28
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNOME/libsigc++/2.2
+PKG_MD5SUM:=73419b477f3bb9ddb9905c88a92f4b4c
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,34 +24,25 @@ define Package/libsigcxx
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=typesafe callback system for standard C++
-  URL:=http://libsigc++.sourceforge.net/
-  DEPENDS:=+uclibcxx
+  URL:=http://libsigc.sourceforge.net/
+  DEPENDS:=+libstdcpp
 endef
 
 define Package/libsigcxx/description
- It allows you to define signals and to connect those signals to any 
- callback function, either global or a member function, regardless of 
+ It allows you to define signals and to connect those signals to any
+ callback function, either global or a member function, regardless of
  whether it is static or virtual.
 endef
 
 TARGET_CFLAGS += $(FPIC)
 
+TARGET_CPPFLAGS +=  \
+       -fno-strict-aliasing -fno-inline \
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-CONFIGURE_VARS += \
-       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
-       LDFLAGS="$$$$LDFLAGS" \
-       LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
@@ -68,4 +59,3 @@ define Package/libsigcxx/install
 endef
 
 $(eval $(call BuildPackage,libsigcxx))
-