libs/libtasn1: fix installation issue. (closes #8165)
[openwrt/svn-archive/archive.git] / libs / libtasn1 / Makefile
index 3eccbdf58ea5589c8fa00ece9a3f25d93b4c5041..e7f8f01ada01aa7262f173acf817ef17d0697a40 100644 (file)
@@ -19,7 +19,8 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
        http://josefsson.org/gnutls/releases/libtasn1/
 PKG_MD5SUM:=a733ecdfed3517910e627d24e050979f
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -41,10 +42,6 @@ CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libtasn1-config $(1)/usr/bin/
@@ -52,6 +49,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libtasn1*.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/libtasn1-config
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/libtasn1-config
 endef