libs/libtasn1: fix installation issue. (closes #8165)
[openwrt/svn-archive/archive.git] / libs / libtasn1 / Makefile
index d4af9a5f905480d90d41e9e25b21b5aee9519bf8..e7f8f01ada01aa7262f173acf817ef17d0697a40 100644 (file)
@@ -1,15 +1,14 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2005-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtasn1
-PKG_VERSION:=1.1
+PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,7 +17,10 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/libtasn1/ \
        http://josefsson.org/gnutls/releases/libtasn1/
-PKG_MD5SUM:=93b43cc5013bda4d8bf64508f1566c54
+PKG_MD5SUM:=a733ecdfed3517910e627d24e050979f
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -34,39 +36,25 @@ define Package/libtasn1/description
  Distinguish Encoding Rules (DER) manipulation.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-       $(call libtool_disable_rpath)
-endef
+TARGET_CFLAGS += $(FPIC)
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
+CONFIGURE_ARGS += \
+               --enable-shared \
+               --enable-static
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libtasn1-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libtasn1-config $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libtasn1*.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/libtasn1-config
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/libtasn1-config
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libtasn1-config \
-               $(STAGING_DIR)/usr/include/libtasn1.h \
-               $(STAGING_DIR)/usr/lib/libtasn1.{a,so*} \
-               $(STAGING_DIR)/usr/share/aclocal/libtasn1.m4
-endef
-
 define Package/libtasn1/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.so.* $(1)/usr/lib/