[packages] libtorrent: update to r1123 (#6624)
[openwrt/svn-archive/archive.git] / libs / libtorrent / Makefile
index 06ee3464bc27cd6aae1e1c5cbbe871d6b247317a..40b672a3f6ca39c3fe34d8a602be58ffd78379bf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 
-PKG_REV:=1087
-PKG_VERSION:=0.12.4_r$(PKG_REV)
-PKG_RELEASE:=4
+PKG_REV:=1123
+PKG_VERSION:=0.12.6_r$(PKG_REV)
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -38,10 +38,11 @@ define Package/libtorrent/description
  the speed of the official client.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
 
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
+TARGET_CPPFLAGS += -fno-inline
 
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \