[packages] libtorrent: update to r1123 (#6624)
[openwrt/svn-archive/archive.git] / libs / libtorrent / Makefile
index 0e73e38834d391dd0749f1a65e980560ba5652b9..40b672a3f6ca39c3fe34d8a602be58ffd78379bf 100644 (file)
@@ -1,20 +1,22 @@
 #
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
-PKG_VERSION:=0.11.9
-PKG_RELEASE:=3
 
 
+PKG_REV:=1123
+PKG_VERSION:=0.12.6_r$(PKG_REV)
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
-PKG_MD5SUM:=8974dc9499b382a09fb952cabcfef9a0
+PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
 
 PKG_FIXUP = libtool
 
 
 PKG_FIXUP = libtool
 
@@ -36,7 +38,11 @@ define Package/libtorrent/description
  the speed of the official client.
 endef
 
  the speed of the official client.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
+
+TARGET_CPPFLAGS += -fno-inline
 
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \
 
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \
@@ -46,6 +52,11 @@ CONFIGURE_ARGS+= \
        --disable-debug \
        --enable-openssl \
 
        --disable-debug \
        --enable-openssl \
 
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); ./autogen.sh );
+       $(call Build/Configure/Default)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \