[package] fix libtorrent build failure (#6981)
[openwrt/svn-archive/archive.git] / libs / libtorrent / Makefile
index a3a87e8582fb0b1c2ed67f22efeed708a753e910..5cfe8b8b4afcd279f84497a3f1a42768c4e86106 100644 (file)
@@ -1,25 +1,26 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
-
-PKG_REV:=1087
-PKG_VERSION:=0.12.4_r$(PKG_REV)
+PKG_REV:=1130
+PKG_VERSION:=0.12.6_r$(PKG_REV)
 PKG_RELEASE:=3
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=svn
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,17 +33,18 @@ define Package/libtorrent
 endef
 
 define Package/libtorrent/description
- LibTorrent is a BitTorrent library written in C++ for *nix, with a focus 
- on high performance and good code. The library differentiates itself from 
- other implementations by transfering directly from file pages to the 
- network stack. On high-bandwidth connections it is able to seed at 3 times 
+ LibTorrent is a BitTorrent library written in C++ for *nix, with a focus
+ on high performance and good code. The library differentiates itself from
+ other implementations by transfering directly from file pages to the
+ network stack. On high-bandwidth connections it is able to seed at 3 times
  the speed of the official client.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
 
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
+TARGET_CPPFLAGS += -fno-inline
 
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \
@@ -57,12 +59,6 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/torrent $(1)/usr/include/