[package] update libtorrent to r1093 (#5218)
[openwrt/svn-archive/archive.git] / libs / libtorrent / Makefile
index 06ee3464bc27cd6aae1e1c5cbbe871d6b247317a..c8d71729ac4ff77bd076c0c69aaa8bd92287c8a2 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 
-PKG_REV:=1087
+PKG_REV:=1093
 PKG_VERSION:=0.12.4_r$(PKG_REV)
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -38,10 +38,14 @@ define Package/libtorrent/description
  the speed of the official client.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing -fno-inline
+endif
+
+ifneq ($(CONFIG_GCC_VERSION_4_2)$(CONFIG_GCC_VERSION_4_3),)
+TARGET_CPPFLAGS += -fno-inline
+endif
 
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
 
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \