Added -flax-vector-conversions compiler option
[openwrt/svn-archive/archive.git] / libs / libtwin / Makefile
index 91ec11475b222de98eba5658ef466152ca1ac3b6..aa63331d5fbdc8208eae649d24b6df49b6628904 100644 (file)
@@ -10,11 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtwin
 PKG_VERSION:=0.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ozlabs.org/~jk/projects/petitboot/downloads/
 PKG_MD5SUM:=ebd7c5cca3c9e108208a7bf17b256a6c
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,6 +27,8 @@ define Package/libtwin
   URL:=
 endef
 
+TARGET_CFLAGS += -flax-vector-conversions
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \