[packages] libiconv-full: autoreconf is broken with this package, use patch-libtool...
[openwrt/svn-archive/archive.git] / libs / libupnp / Makefile
index 7480fab687941ca2a276782def62dbfb0325bd86..ac56258eb54615deb43a4698c6ef7307fe4a1067 100644 (file)
@@ -1,65 +1,75 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libupnp
-PKG_VERSION:=1.2.1a
+PKG_VERSION:=1.6.14
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/upnp
-PKG_MD5SUM:=e72b3550bf064eedf080f16f09688891
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/pupnp
+PKG_MD5SUM:=a0497cf15b3e15f7e7ede88b3d04861b
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/libupnp
+define Package/libupnp/Default
   SECTION:=libs
   CATEGORY:=Libraries
+  URL:=http://pupnp.sourceforge.net/
+endef
+
+define Package/libupnp
+  $(call Package/libupnp/Default)
   DEPENDS:=+libpthread
   TITLE:=UPnP SDK library
-  DESCRIPTION:=UPnP (Universal Plug and Play) SDK library.\\\
-    The Universal Plug and Play (UPnP) SDK for Linux provides support \\\
-    for building UPnP-compliant control points, devices, and bridges \\\
-    on Linux.
-  URL:=http://upnp.sourceforge.net/
+  MENU:=1
 endef
 
-define Build/Configure
+define Package/libupnp/description
+The portable SDK for UPnP Devices (libupnp) provides developers with an API and
+open source code for building control points, devices, and bridges that are
+compliant with Version 1.0 of the  Universal Plug and Play Device Architecture
+Specification.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/upnp \
-               $(TARGET_CONFIGURE_OPTS) \
-               OPT_FLAGS="$(TARGET_CFLAGS)" \
-               STRIP=/bin/true
+define Package/libupnp-sample
+  $(call Package/libupnp/Default)
+  DEPENDS:=libupnp
+  TITLE:=UPnP sample applications
 endef
 
-define Package/libupnp/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/upnp/bin/lib{ixml,threadutil,upnp}.so $(1)/usr/lib/
+define Package/libupnp-sample/description
+TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include/upnp
-       $(CP) $(PKG_BUILD_DIR)/upnp/inc/*.h $(STAGING_DIR)/usr/include/upnp/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/upnp/bin/lib{ixml,threadutil,upnp}.so $(STAGING_DIR)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.{a,so*,la} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libupnp.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libupnp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.so.* $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/upnp \
-               $(STAGING_DIR)/usr/lib/lib{ixml,threadutil,upnp}.so
+define Package/libupnp-sample/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/upnp/sample/.libs/* $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/upnp-tvdevice/web
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/upnp/sample/web/* $(1)/etc/upnp-tvdevice
 endef
 
 $(eval $(call BuildPackage,libupnp))
+$(eval $(call BuildPackage,libupnp-sample))