[package] update sources to 4.7.25.3, bump release number (#6100)
[openwrt/svn-archive/archive.git] / libs / libvorbis / Makefile
index 226c85f5d4e8c3cffd194f27c6afbd49d7c0dced..20cb2e00cc08e09fb01bc5c08387301e0e19a4f2 100644 (file)
@@ -1,25 +1,25 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libvorbis
-PKG_VERSION:=1.2.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.2.3
+PKG_RELEASE:=1
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/vorbis/
-PKG_MD5SUM:=478646358c49f34aedcce58948793619
+PKG_MD5SUM:=5aa77f55c0e0aab8eb8ed982335daac8
+
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_INSTALL=1
-
 define Package/libvorbis
   SECTION:=libs
   CATEGORY:=Libraries
@@ -39,11 +39,8 @@ software entity may make full use of the format without license
 fee, royalty or patent concerns.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-oggtest \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --disable-oggtest \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/vorbis/
@@ -58,7 +55,7 @@ endef
 
 define Package/libvorbis/install
        $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libvorbis))