remove UninstallDev
[openwrt/svn-archive/archive.git] / libs / libvorbisidec / Makefile
index b00ef97ece5cc7ea8314e9a08cd606f97b4752ce..63b2504010544e7d2464945c41973c599aa2844d 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libvorbisidec
-PKG_VERSION:=1.2.0-dave
+PKG_VERSION:=1.0.2+svn14261
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
-PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/libv/libvorbisidec/
+PKG_MD5SUM:=bc617d4af1cd74b38d7c51451dd6eff0
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,15 +25,18 @@ define Package/libvorbisidec
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=A fixed-point Ogg/Vorbis decoder library
-  DESCRIPTION:=\
-       libvorbisidec is "tremor", a fixed-point implementation of libvorbis.\\\
-       It also has libogg built-in. It is suitable as a replacement for \\\
-       libvorbis and libogg in tremor-aware applications.\\\
-       Tremor is a decoder only. 
-  URL:=http://http://wiki.xiph.org/index.php/Tremor
+  URL:=http://wiki.xiph.org/index.php/Tremor
+endef
+
+define Package/libvorbisidec/description
+       libvorbisidec is "tremor", a fixed-point implementation of libvorbis.
+       It also has libogg built-in. It is suitable as a replacement for 
+       libvorbis and libogg in tremor-aware applications.
+       Tremor is a decoder only.
 endef
 
 define Build/Configure
+       (cd $(PKG_BUILD_DIR); ./autogen.sh );
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
@@ -48,16 +50,10 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/tremor \
-               $(STAGING_DIR)/usr/lib/libvorbisidec.{a,so*}
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libvorbisidec/install