[package] re-enable ipv6 in apr (#5608)
[openwrt/svn-archive/archive.git] / libs / libxapian / Makefile
index 38e15d454b86bad29544e8d8d75deae485d8394c..0365a3104a03cc35bdee0cfc2623723a3f755dbb 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:
 
 include $(TOPDIR)/rules.mk
 
@@ -29,7 +28,7 @@ define Package/libxapian
   CATEGORY:=Libraries
   TITLE:=xapian
   URL:=http://xapian.org
-  DEPENDS:=+libstdcpp
+  DEPENDS:=+libstdcpp +zlib
 endef
 
 define Build/InstallDev
@@ -58,9 +57,15 @@ define Build/InstallDev
        $(SED) 's,prefix=",prefix="$(STAGING_DIR),g' $(2)/bin/xapian-config
 
        #FIXME: Libtool should handle this
-       $(SED) \
+       if [ -f $(TOOLCHAIN_DIR)/usr/lib/libstdc++.la ]; then \
+         $(SED) \
                "s,$(STAGING_DIR)/usr/lib/libstdc++,$(TOOLCHAIN_DIR)/usr/lib/libstdc++,g" \
-               $(1)/usr/lib/libxapian.la
+               $(1)/usr/lib/libxapian.la ; \
+       else \
+         $(SED) \
+               "s,$(STAGING_DIR)/usr/lib/libstdc++,$(TOOLCHAIN_DIR)/lib/libstdc++,g" \
+               $(1)/usr/lib/libxapian.la ; \
+       fi
 endef
 
 define Package/libxapian/install