[packages] libxml2: enable debug module (#8289)
[openwrt/svn-archive/archive.git] / libs / libxml2 / Makefile
index b76097024461c159ef5a239d89c0c259883daee7..1fe629ce2322071ba183f0bbe434de7b6a6072f8 100644 (file)
@@ -1,48 +1,47 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxml2
-PKG_VERSION:=2.6.20
-PKG_RELEASE:=1
+PKG_VERSION:=2.7.7
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=8f0b3ce721bda11401e656b90ba4e78c
-PKG_CAT:=zcat
+PKG_MD5SUM:=9abc9959823ca9ff904f1fbcf21df066
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-
 define Package/libxml2
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libpthread +zlib
   TITLE:=Gnome XML library
   URL:=http://xmlsoft.org/
+  DEPENDS:=+libpthread +zlib
 endef
 
 define Package/libxml2/description
- A library for manipulating XML and HTML resources.
 A library for manipulating XML and HTML resources.
 endef
 
+TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
-       --without-c14n \
+       --with-c14n \
        --without-catalog \
-       --without-debug \
+       --with-debug \
        --without-docbook \
        --with-html \
        --without-ftp \
@@ -68,46 +67,38 @@ CONFIGURE_ARGS += \
        --with-xptr \
        --with-zlib \
 
-
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
-endef
-
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libxml2 $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir}/libxml2,-I$(STAGING_DIR)/usr/include/libxml2,g' $(STAGING_DIR)/usr/bin/xml2-config
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/bin/xml2-config
-       $(SED) 's,^includedir=.*,includedir=$(STAGING_DIR)/usr/include,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc
-       $(SED) 's,^libdir=.*,libdir=$(STAGING_DIR)/usr/lib,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc
-endef
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(2)/bin/
+       $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(2)/bin/xml2-config
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/xml2-config \
-               $(STAGING_DIR)/usr/include/libxml2 \
-               $(STAGING_DIR)/usr/lib/libxml2.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc
-endef
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libxml2 \
+               $(1)/usr/include/
 
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxml2.{la,a,so*} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc \
+               $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DIR) $(2)/share/aclocal/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
+               $(2)/share/aclocal
+endef
 
 define Package/libxml2/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* \
+               $(1)/usr/lib/
 endef
 
 
 $(eval $(call BuildPackage,libxml2))
-