[packages] libxml2: update to 2.7.7
[openwrt/svn-archive/archive.git] / libs / libxml2 / Makefile
index ae22a06d185e7eb2ea193ff884ef0c8438bb4e8a..586a75618b7f03f794dd0aecbb0a20c91e02de67 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxml2
-PKG_VERSION:=2.7.5
+PKG_VERSION:=2.7.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=2e29ca610579438714ebb1e4010a0ece
+PKG_MD5SUM:=9abc9959823ca9ff904f1fbcf21df066
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -24,9 +24,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libxml2
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libpthread +zlib
   TITLE:=Gnome XML library
   URL:=http://xmlsoft.org/
+  DEPENDS:=+libpthread +zlib
 endef
 
 define Package/libxml2/description
@@ -38,7 +38,7 @@ TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
-       --without-c14n \
+       --with-c14n \
        --without-catalog \
        --without-debug \
        --without-docbook \