[packages] libxml2: update to v2.7.5
[openwrt/svn-archive/archive.git] / libs / libxml2 / Makefile
index 0f27a5129c5dc6aafcde80e436657e34443fc03e..ae22a06d185e7eb2ea193ff884ef0c8438bb4e8a 100644 (file)
@@ -1,27 +1,26 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxml2
-PKG_VERSION:=2.7.2
-PKG_RELEASE:=2
+PKG_VERSION:=2.7.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=dc43ff7ae6aded45f578c87b7b0c8766
+PKG_MD5SUM:=2e29ca610579438714ebb1e4010a0ece
+
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_INSTALL=1
-
 define Package/libxml2
   SECTION:=libs
   CATEGORY:=Libraries
@@ -78,8 +77,8 @@ define Build/InstallDev
                $(1)/usr/include/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/libxml2.{la,so*} \
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxml2.{la,a,so*} \
                $(1)/usr/lib/
 
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
@@ -95,7 +94,7 @@ endef
 
 define Package/libxml2/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* \
                $(1)/usr/lib/
 endef