Port tor to 0.1.1.24 (#567)
[openwrt/svn-archive/archive.git] / libs / libxml2 / Makefile
index 1fe23d6f36aae55c8836301943c9d8c0c0bdf875..f8bf5c012b0076918f65fcbdf197a50545345c5e 100644 (file)
@@ -12,13 +12,13 @@ PKG_NAME:=libxml2
 PKG_VERSION:=2.6.20
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
 PKG_MD5SUM:=8f0b3ce721bda11401e656b90ba4e78c
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -28,83 +28,51 @@ define Package/libxml2
   CATEGORY:=Libraries
   DEPENDS:=+libpthread +zlib
   TITLE:=Gnome XML library
-  DESCRIPTION:=A library for manipulating XML and HTML resources.
+  DESCRIPTION:=\
+       A library for manipulating XML and HTML resources.
   URL:=http://xmlsoft.org/
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-gnu-ld \
-                       --without-c14n \
-                       --without-catalog \
-                       --without-debug \
-                       --without-docbook \
-                       --with-html \
-                       --without-ftp \
-                       --without-http \
-                       --without-iconv \
-                       --without-iso8859x \
-                       --without-legacy \
-                       --with-output \
-                       --without-pattern \
-                       --without-push \
-                       --without-python \
-                       --with-reader \
-                       --without-readline \
-                       --without-regexps \
-                       --with-sax1 \
-                       --with-schemas \
-                       --with-threads \
-                       --with-tree \
-                       --with-valid \
-                       --with-writer \
-                       --with-xinclude \
-                       --with-xpath \
-                       --with-xptr \
-                       --with-zlib \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --without-c14n \
+               --without-catalog \
+               --without-debug \
+               --without-docbook \
+               --with-html \
+               --without-ftp \
+               --without-http \
+               --without-iconv \
+               --without-iso8859x \
+               --without-legacy \
+               --with-output \
+               --without-pattern \
+               --without-push \
+               --without-python \
+               --with-reader \
+               --without-readline \
+               --without-regexps \
+               --with-sax1 \
+               --with-schemas \
+               --with-threads \
+               --with-tree \
+               --with-valid \
+               --with-writer \
+               --with-xinclude \
+               --with-xpath \
+               --with-xptr \
+               --with-zlib \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libxml2/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(STAGING_DIR)/usr/bin/
@@ -131,4 +99,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc
 endef
 
+define Package/libxml2/install
+       install -d -m0755 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libxml2))