[packages] libxslt: update to v1.1.26, cleanup
[openwrt/svn-archive/archive.git] / libs / libxslt / Makefile
index a6f81c695b1d3510ffe966b96167428337e67439..4dce40224d073f8096b4730b7b9b458ff81ec524 100644 (file)
@@ -1,21 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxslt
-PKG_VERSION:=1.1.24
+PKG_VERSION:=1.1.26
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=e83ec5d27fc4c10c6f612879bea9a153
+PKG_MD5SUM:=e61d0364a30146aaa3001296f853b2b9
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,50 +45,60 @@ define Package/xsltproc/description
        XSLT XML transformation utility
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --with-libxml-prefix="$(STAGING_DIR)/usr" \
-               --with-libxml-include-prefix="$(STAGING_DIR)/usr/include" \
-               --with-libxml-libs-prefix="$(STAGING_DIR)/usr/lib" \
-               --without-python \
-               --without-crypto \
-               --without-debug \
-               --without-mem-debug \
-               --without-debugger \
-               , \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/libxml2" \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --without-python \
+       --without-crypto \
+       --without-debug \
+       --without-mem-debug \
+       --without-debugger \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xslt-config $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xsltproc $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libxslt $(1)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxslt.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(1)/usr/bin/xslt-config
-       $(SED) 's,-L$$$${libdir},,g' $(1)/usr/bin/xslt-config
-       $(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(1)/usr/bin/xslt-config
-       $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(1)/usr/bin/xslt-config
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt $(1)/usr/lib \
+               $(1)/usr/lib/pkgconfig $(2)/share/aclocal
+
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/xslt-config \
+               $(2)/bin/
+
+       ln -sf $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
+
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/xslt-config
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/libxslt/* \
+               $(1)/usr/include/libxslt/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxslt.{la,a,so*} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc \
+               $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
+               $(2)/share/aclocal
 endef
 
 define Package/libxslt/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* \
+               $(1)/usr/lib/
 endef
 
 define Package/xsltproc/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xsltproc $(1)/usr/bin/
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/xsltproc \
+               $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libxslt))