fix various makefile errors (#1236)
[openwrt/svn-archive/archive.git] / libs / libxslt / Makefile
index 89f1e747af97884a59217864369b8e0f4ce7c453..8c0cb389c739310b0599a215148c29292c3e7c0a 100644 (file)
@@ -12,13 +12,13 @@ PKG_NAME:=libxslt
 PKG_VERSION:=1.1.14
 PKG_RELEASE:=1
 
 PKG_VERSION:=1.1.14
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
 PKG_MD5SUM:=db71660bb7d01ccd4e6be990af8d813b
 PKG_CAT:=zcat
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
 PKG_MD5SUM:=db71660bb7d01ccd4e6be990af8d813b
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -28,64 +28,34 @@ define Package/libxslt
   CATEGORY:=Libraries
   DEPENDS:=+libxml2
   TITLE:=Gnome XSLT library
   CATEGORY:=Libraries
   DEPENDS:=+libxml2
   TITLE:=Gnome XSLT library
-  DESCRIPTION:=A library for XML transformation using XSLT.
+  DESCRIPTION:=\
+       A library for XML transformation using XSLT.
   URL:=http://xmlsoft.org/XSLT/
 endef
 
 define Build/Configure
   URL:=http://xmlsoft.org/XSLT/
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-gnu-ld \
-                       --with-libxml-prefix="$(STAGING_DIR)/usr" \
-                       --with-libxml-include-prefix="$(STAGING_DIR)/usr/include" \
-                       --with-libxml-libs-prefix="$(STAGING_DIR)/usr/lib" \
-                       --without-python \
-                       --without-crypto \
-                       --without-debug \
-                       --without-mem-debug \
-                       --without-debugger \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --with-libxml-prefix="$(STAGING_DIR)/usr" \
+               --with-libxml-include-prefix="$(STAGING_DIR)/usr/include" \
+               --with-libxml-libs-prefix="$(STAGING_DIR)/usr/lib" \
+               --without-python \
+               --without-crypto \
+               --without-debug \
+               --without-mem-debug \
+               --without-debugger \
+               , \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/libxml2" \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libxslt/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/xslt-config $(STAGING_DIR)/usr/bin/
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/xslt-config $(STAGING_DIR)/usr/bin/
@@ -96,9 +66,13 @@ define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/bin/xslt-config
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/bin/xslt-config
-       $(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(STAGING_DIR)/usr/bin/xslt-config
        $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/bin/xslt-config
        $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/bin/xslt-config
+       $(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(STAGING_DIR)/usr/bin/xslt-config
        $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/bin/xslt-config
        $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/bin/xslt-config
+       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+       $(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+       $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
 endef
 
 define Build/UninstallDev
 endef
 
 define Build/UninstallDev
@@ -109,4 +83,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
 endef
 
                $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
 endef
 
+define Package/libxslt/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libxslt))
 $(eval $(call BuildPackage,libxslt))