cleanup
[openwrt/svn-archive/archive.git] / libs / mysql / Makefile
index 912f06f9cf4665cf68269216d866b0ca9a6ccc5e..201a555da6e2a5baab9c739a4815ba2c7d17d6f2 100644 (file)
@@ -48,10 +48,6 @@ define Build/Configure
                CXXFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_atomic_add=yes \
-               ac_atomic_sub=yes \
-               ac_cv_sys_restartable_syscalls=yes \
-               ac_cv_conv_longlong_to_float=yes \
                mysql_cv_compress=yes \
                mysql_cv_gethostname_style=glibc2 \
                ./configure \
@@ -92,6 +88,7 @@ define Build/Configure
                        --without-docs \
                        --without-bench \
                        --without-readline \
+                       --with-named-thread-libs=-lpthread \
        );
 endef