fixed another UninstallDev part
[openwrt/svn-archive/archive.git] / libs / neon / Makefile
index efc7b840472fd9667f38557411089c4f9b0288b1..a8150eeb65f4e7a48761f0b593abe225b1f48888 100644 (file)
@@ -1,10 +1,10 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# crazy_imp
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -61,13 +61,15 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/neon.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED)  "s,\=\/usr,\=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/bin/neon-config
        $(SED)  "s,"libdir\=\'/usr/lib\'",libdir='$(STAGING_DIR)/usr/lib\'," $(STAGING_DIR)/usr/lib/libneon.la
+       $(SED)  "s,"prefix\=/usr",prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/neon.pc
+       $(SED)  "s,"exec_prefix\=/usr",exec_prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/neon.pc
 endef
 
 define Build/UninstallDev
-       rm      $(STAGING_DIR)/usr/bin/neon-config \
+       rm -rf  $(STAGING_DIR)/usr/bin/neon-config \
                $(STAGING_DIR)/usr/lib/{libneon.a,libneon.la,libneon.so,libneon.so.26,libneon.so.26.0.3} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/neon.pc
-       rm -rf  $(STAGING_DIR)/usr/include/neon
+               $(STAGING_DIR)/usr/lib/pkgconfig/neon.pc \
+               $(STAGING_DIR)/usr/include/neon
 endef
 
 define Package/neon/install