[PATCH] Enable 802.11 module in net-snmp
[openwrt/svn-archive/archive.git] / libs / net-snmp / Makefile
index 4cb66fce627db58695b0b8cab06e533678655cf1..d6d851a0b15847c20f26c94c5f48a506a8a23f44 100644 (file)
@@ -1,24 +1,90 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.1.2
-PKG_RELEASE:=2.1
+PKG_RELEASE:=5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
 PKG_MD5SUM:=8080555ab3f90011f25d5122042d9a8d
-PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+include $(INCLUDE_DIR)/package.mk
+
+define Package/net-snmp/Default
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://www.net-snmp.org/
+endef
+
+define Package/net-snmp/Default/description
+ Simple Network Management Protocol (SNMP) is a widely used protocol for 
+ monitoring the health and welfare of network equipment (eg. routers), 
+ computer equipment and even devices like UPSs. Net-SNMP is a suite of 
+ applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both 
+ IPv4 and IPv6.
+endef
+
+
+define Package/libnetsnmp
+$(call Package/net-snmp/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libelf
+  TITLE:=Open source SNMP implementation (librairies)
+endef
+
+define Package/libnetsnmp/description
+$(call Package/net-snmp/Default/description)
+ .
+ This package contains shared libraries, needed by other programs.
+endef
+
+
+define Package/snmp-utils
+$(call Package/net-snmp/Default)
+  DEPENDS:=+libnetsnmp
+  TITLE:=Open source SNMP implementation (utilities)
+endef
+
+define Package/snmp-utils/description
+$(call Package/net-snmp/Default/description)
+ .
+ This package contains SNMP client utilities.
+endef
+
+
+define Package/snmpd
+$(call Package/net-snmp/Default)
+  DEPENDS:=+libnetsnmp
+  TITLE:=Open source SNMP implementation (daemon)
+endef
+
+define Package/snmpd/description
+$(call Package/net-snmp/Default/description)
+ .
+ This package contains the SNMP agent, dynamically linked.
+endef
+
+
+define Package/snmpd-static
+$(call Package/net-snmp/Default)
+  TITLE:=Open source SNMP implementation (daemon)
+  DEPENDS:=+libelf
+endef
+
+define Package/snmpd-static/description
+$(call Package/net-snmp/Default/description)
+ .
+ This package contains the SNMP agent, statically linked.
+endef
+
 
 SNMP_MIB_MODULES_INCLUDED = \
        host/hr_device \
@@ -29,6 +95,7 @@ SNMP_MIB_MODULES_INCLUDED = \
        host/hr_proc \
        host/hr_storage \
        host/hr_system \
+       ieee802dot11 \
        mibII/at \
        mibII/icmp \
        mibII/interfaces \
@@ -61,7 +128,6 @@ SNMP_MIB_MODULES_EXCLUDED = \
        agent_mibs \
        agentx \
        host \
-       ieee802dot11 \
        mibII \
        notification \
        snmpv3mibs \
@@ -73,7 +139,9 @@ SNMP_TRANSPORTS_INCLUDED = Callback UDP
 
 SNMP_TRANSPORTS_EXCLUDED = TCP TCPv6 UDPv6 Unix
 
-PKG_CONFIGURE_OPTIONS = \
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --with-endianness=little \
@@ -86,125 +154,17 @@ PKG_CONFIGURE_OPTIONS = \
        --disable-debugging \
        --disable-ipv6 \
        --disable-manuals \
-       --disable-mib-loading \
        --disable-mibs \
        --disable-scripts \
        --with-out-mib-modules="$(SNMP_MIB_MODULES_EXCLUDED)" \
        --with-mib-modules="$(SNMP_MIB_MODULES_INCLUDED)" \
        --with-out-transports="$(SNMP_TRANSPORTS_EXCLUDED)" \
        --with-transports="$(SNMP_TRANSPORTS_INCLUDED)" \
-       --without-opaque-special-types \
        --without-openssl \
        --without-libwrap \
        --without-rpm \
        --without-zlib \
 
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libnetsnmp
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=+libelf
-  TITLE:=Open source SNMP implementation (librairies)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (libraries).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains shared libraries, needed by other programs.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmp-utils
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libnetsnmp
-  TITLE:=Open source SNMP implementation (utilities)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (utilities).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains SNMP client utilities.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmpd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libnetsnmp
-  TITLE:=Open source SNMP implementation (daemon)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (daemon).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains the SNMP agent, dynamically linked.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmpd/conffiles
-/etc/default/snmpd
-/etc/snmp/snmpd.conf
-endef
-
-define Package/snmpd-static
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Open source SNMP implementation (daemon)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (daemon).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains the SNMP agent, statically linked.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmpd-static/conffiles
-/etc/default/snmpd
-/etc/snmp/snmpd.conf
-endef
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_header_pcap_h=no \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       $(PKG_CONFIGURE_OPTIONS) \
-       );
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
@@ -212,62 +172,71 @@ define Build/Compile
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                all install
        ( cd $(PKG_INSTALL_DIR); mv ./usr/sbin/snmpd ./usr/sbin/snmpd-shared; )
-ifneq ($(CONFIG_PACKAGE_snmpd-static),)
+       #ifneq ($(CONFIG_PACKAGE_snmpd-static),)
        ( cd $(PKG_BUILD_DIR); rm -f agent/snmpd; )
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -static" \
+               LDFLAGS="$(TARGET_LDFLAGS) -static" \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                all install
        ( cd $(PKG_INSTALL_DIR); mv ./usr/sbin/snmpd ./usr/sbin/snmpd-static; )
-endif
+       #endif
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(2)/bin/
+       $(SED) 's,=/usr,=$(STAGING_DIR)/usr,g' $(2)/bin/net-snmp-config
+
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/net-snmp $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libnetsnmp/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.so.* $(1)/usr/lib/
 endef
 
-define Package/snmpd/install
-       install -d -m0755 $(1)/etc/snmp
-       install -m0644 ./files/snmpd.conf $(1)/etc/snmp/snmpd.conf
-       install -d -m0755 $(1)/etc/default
-       install -m0644 ./files/snmpd.default $(1)/etc/default/snmpd
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/snmpd.init $(1)/etc/init.d/snmpd
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/snmpd-shared $(1)/usr/sbin/snmpd
+define Package/snmpd/conffiles
+/etc/default/snmpd
+/etc/config/snmpd
 endef
 
-define Package/snmpd-static/install
-       install -d -m0755 $(1)/etc/snmp
-       install -m0644 ./files/snmpd.conf $(1)/etc/snmp/snmpd.conf
-       install -d -m0755 $(1)/etc/default
-       install -m0644 ./files/snmpd.default $(1)/etc/default/snmpd
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/snmpd.init $(1)/etc/init.d/snmpd
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/snmpd-static $(1)/usr/sbin/snmpd
+define Package/snmpd/install
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/snmpd.conf $(1)/etc/config/snmpd
+       $(INSTALL_DIR) $(1)/etc/snmp
+       ln -sf /var/run/snmpd.conf $(1)/etc/snmp/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_DATA) ./files/snmpd.default $(1)/etc/default/snmpd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/snmpd.init $(1)/etc/init.d/snmpd
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/snmpd-shared $(1)/usr/sbin/snmpd
 endef
 
-define Package/snmp-utils/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/snmp{get,set,status,test,trap,walk} $(1)/usr/bin/
+define Package/snmpd-static/conffiles
+/etc/default/snmpd
+/etc/config/snmpd
 endef
 
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/net-snmp $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(STAGING_DIR)/usr/lib/
+define Package/snmpd-static/install
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/snmpd.conf $(1)/etc/config/snmpd
+       $(INSTALL_DIR) $(1)/etc/snmp
+       ln -sf /var/run/snmpd.conf $(1)/etc/snmp/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_DATA) ./files/snmpd.default $(1)/etc/default/snmpd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/snmpd.init $(1)/etc/init.d/snmpd
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/snmpd-static $(1)/usr/sbin/snmpd
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/net-snmp-config \
-               $(STAGING_DIR)/usr/include/net-snmp \
-               $(STAGING_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*}
+define Package/snmp-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/snmp{get,set,status,test,trap,walk} $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libnetsnmp))