[packages] opal fails when doing fullbuilds
[openwrt/svn-archive/archive.git] / libs / opal / Makefile
index 52aeeab9cc0dedb2f7c546a2ec9a46295d74f0e7..380a8b29760c833e09257bf85260ec23b0360869 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 8274 2007-07-31 11:22:44Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opal
-PKG_VERSION:=3.1.2
+PKG_VERSION:=3.2.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
 PKG_SOURCE_URL:=@SF/opalvoip
-PKG_MD5SUM:=07fd0ed5ae95e1b88874e1fb9669e4f3
+PKG_MD5SUM:=405ba3b03ec706b6e6f873de340937e2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 
@@ -36,9 +35,10 @@ define Package/libopal/description
        Open Phone Abstraction Library, implementation of the ITU H.323
        teleconferencing protocol, and successor of the openh323 library. It
        supports not only the H.323 protocol but also SIP and IAX2.
-
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-audio \
        --disable-video \
@@ -51,6 +51,7 @@ CONFIGURE_ARGS += \
        --disable-ivr \
        --disable-rfc4175 \
        --disable-versioncheck \
+       --disable-theora \
        --enable-localgsm
 
 CONFIGURE_VARS += \
@@ -65,8 +66,4 @@ define Build/InstallDev
        ln -sf $(PKG_NAME)_$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
 endef
 
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
-endef
-
 $(eval $(call BuildPackage,libopal))