Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / libs / opencdk / Makefile
index 4271cf19ebde34412a2cd287007be6faac5732dc..78d2e514e65a4c5ada0d9c3670aecd9a86486768 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
 PKG_VERSION:=0.6.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
@@ -19,6 +19,7 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
        http://josefsson.org/gnutls/releases/opencdk/
 PKG_MD5SUM:=813d62d7afe7b2c2d8f3df0a6c9d9331
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -65,14 +66,14 @@ define Build/InstallDev
                $(1)/usr/include/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{la,so*} \
                $(1)/usr/lib/
 endef
 
 define Package/libopencdk/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* \
                $(1)/usr/lib/
 endef