Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / libs / opencdk / Makefile
index a9f3f77bc9a2c1e64c5445e5a77347967cad9a85..78d2e514e65a4c5ada0d9c3670aecd9a86486768 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006, 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
-PKG_VERSION:=0.5.5
-PKG_RELEASE:=1
+PKG_VERSION:=0.6.6
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
@@ -18,37 +18,32 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
        http://josefsson.org/gnutls/releases/opencdk/
-PKG_MD5SUM:=aaff60107f0153873192ffda00699a96
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=813d62d7afe7b2c2d8f3df0a6c9d9331
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 define Package/libopencdk
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libgcrypt
+  DEPENDS:=+libgcrypt zlib
   TITLE:=The Open Crypto Development Kit library
-  DESCRIPTION:=\
-       This library provides basic parts of the OpenPGP message format.\\\
-       For reference, please read the rfc2440.txt in the doc/ directory.\\\
-       Due to some possible security problems, the library also implements \\\
-       parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange \\\
-       messages with earlier PGP version < 7, you should use the compat mode.
   URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/
 endef
 
+define Package/libopencdk/description
+       This library provides basic parts of the OpenPGP message format.
+       For reference, please read the rfc2440.txt in the doc/ directory.
+       Due to some possible security problems, the library also implements 
+       parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange 
+       messages with earlier PGP version < 7, you should use the compat mode.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               configure.ac \
-               acinclude.m4 \
-               aclocal.m4 \
-               Makefile.in \
-               config.h.in \
-               configure \
-       );
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
@@ -56,31 +51,31 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/opencdk-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/opencdk.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/opencdk-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/opencdk-config
+
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/opencdk.h \
+               $(1)/usr/include/
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/opencdk-config \
-               $(STAGING_DIR)/usr/include/opencdk.h \
-               $(STAGING_DIR)/usr/lib/libopencdk.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{la,so*} \
+               $(1)/usr/lib/
 endef
 
 define Package/libopencdk/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libopencdk))