Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / libs / opencdk / Makefile
index c50ef911cf4417c542c4eb6f942275b9f2020b2a..78d2e514e65a4c5ada0d9c3670aecd9a86486768 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006, 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
-PKG_VERSION:=0.6.4
-PKG_RELEASE:=1
+PKG_VERSION:=0.6.6
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
@@ -18,14 +18,13 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
        http://josefsson.org/gnutls/releases/opencdk/
-PKG_MD5SUM:=7bfc820bcdc08f0c31f860710368071e
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=813d62d7afe7b2c2d8f3df0a6c9d9331
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 define Package/libopencdk
   SECTION:=libs
   CATEGORY:=Libraries
@@ -42,6 +41,8 @@ define Package/libopencdk/description
        messages with earlier PGP version < 7, you should use the compat mode.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -50,31 +51,31 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/opencdk-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/opencdk.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{a,so*} $(1)/usr/lib/
-endef
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/opencdk-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/opencdk-config
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/opencdk-config \
-               $(STAGING_DIR)/usr/include/opencdk.h \
-               $(STAGING_DIR)/usr/lib/libopencdk.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/opencdk.h \
+               $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{la,so*} \
+               $(1)/usr/lib/
 endef
 
 define Package/libopencdk/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libopencdk))