add opencdk update patch by Simon Josefsson (#2399)
[openwrt/svn-archive/archive.git] / libs / opencdk / Makefile
index c3a6d0bcbe72aeb543220b283e338a0e7bcfd11d..a7016c18f7530caaa3f764d68b806e3b11ee5a82 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006, 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
-PKG_VERSION:=0.5.5
+PKG_VERSION:=0.6.4
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
        ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
        http://josefsson.org/gnutls/releases/opencdk/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
        ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
        http://josefsson.org/gnutls/releases/opencdk/
-PKG_MD5SUM:=aaff60107f0153873192ffda00699a96
+PKG_MD5SUM:=7bfc820bcdc08f0c31f860710368071e
 PKG_CAT:=bzcat
 
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,69 +29,31 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libopencdk
   SECTION:=libs
   CATEGORY:=Libraries
 define Package/libopencdk
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libgcrypt
+  DEPENDS:=+libgcrypt zlib
   TITLE:=The Open Crypto Development Kit library
   TITLE:=The Open Crypto Development Kit library
-  DESCRIPTION:=The Open Crypto Development Kit library.\\\
-    This library provides basic parts of the OpenPGP message format.\\\
-    For reference, please read the rfc2440.txt in the doc/ directory.\\\
-    Due to some possible security problems, the library also implements \\\
-    parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange \\\
-    messages with earlier PGP version < 7, you should use the compat mode.
+  DESCRIPTION:=\
+       This library provides basic parts of the OpenPGP message format.\\\
+       For reference, please read the rfc2440.txt in the doc/ directory.\\\
+       Due to some possible security problems, the library also implements \\\
+       parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange \\\
+       messages with earlier PGP version < 7, you should use the compat mode.
   URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/
 endef
 
 define Build/Configure
   URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.ac ; \
-               touch acinclude.m4 ; \
-               touch aclocal.m4 ; \
-               touch Makefile.in ; \
-               touch config.h.in ; \
-               touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libopencdk/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/opencdk-config $(STAGING_DIR)/usr/bin/
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/opencdk-config $(STAGING_DIR)/usr/bin/
@@ -108,4 +70,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libopencdk.{a,so*}
 endef
 
                $(STAGING_DIR)/usr/lib/libopencdk.{a,so*}
 endef
 
+define Package/libopencdk/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libopencdk))
 $(eval $(call BuildPackage,libopencdk))