[package] uclibc++: update to 0.2.3
[openwrt/svn-archive/archive.git] / libs / opencdk / Makefile
index d16ff2fb9ffefce05915056b904686dc8df84979..dedef401038f500a9b12a7de3a43937a8d1ac3d0 100644 (file)
@@ -1,45 +1,43 @@
-# 
-# Copyright (C) 2006, 2007 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
-PKG_VERSION:=0.6.4
-PKG_RELEASE:=1
+PKG_VERSION:=0.6.6
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
-       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/ \
-       http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
-       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
-       http://josefsson.org/gnutls/releases/opencdk/
-PKG_MD5SUM:=7bfc820bcdc08f0c31f860710368071e
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/attic/opencdk
+PKG_MD5SUM:=813d62d7afe7b2c2d8f3df0a6c9d9331
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 define Package/libopencdk
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+libgcrypt zlib
   TITLE:=The Open Crypto Development Kit library
-  DESCRIPTION:=\
-       This library provides basic parts of the OpenPGP message format.\\\
-       For reference, please read the rfc2440.txt in the doc/ directory.\\\
-       Due to some possible security problems, the library also implements \\\
-       parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange \\\
+  URL:=ftp://ftp.gnutls.org/pub/gnutls/attic/opencdk/
+endef
+
+define Package/libopencdk/description
+       This library provides basic parts of the OpenPGP message format.
+       For reference, please read the rfc2440.txt in the doc/ directory.
+       Due to some possible security problems, the library also implements 
+       parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange 
        messages with earlier PGP version < 7, you should use the compat mode.
-  URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -48,31 +46,31 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/opencdk-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/opencdk.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{a,so*} $(1)/usr/lib/
-endef
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/opencdk-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/opencdk-config
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/opencdk-config \
-               $(STAGING_DIR)/usr/include/opencdk.h \
-               $(STAGING_DIR)/usr/lib/libopencdk.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/opencdk.h \
+               $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{la,so*} \
+               $(1)/usr/lib/
 endef
 
 define Package/libopencdk/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libopencdk))