[packages] polarssl: update to 0.14.2, fix & add descriptions
[openwrt/svn-archive/archive.git] / libs / openh323 / Makefile
index e7320e7787d5e1f5e44e2aa77814f0ae3a906789..665fb0d22e52d11813358f7867c181177658e59b 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -27,6 +26,8 @@ define Package/libopenh323
   URL:=http://openh323.sourceforge.net/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-minsize \
        --enable-audio \
@@ -36,16 +37,12 @@ CONFIGURE_VARS += \
        CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
 
 MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       CCFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
+       CCFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
        optnoshared
 
 define Build/InstallDev
        ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
 endef
 
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
-endef
-
 $(eval $(call BuildPackage,libopenh323))