Add maintainer to openldap Makefile
[openwrt/svn-archive/archive.git] / libs / openldap / Makefile
index 766de5ca7eeb3efe450d2344e78ff6c5e0278410..826af7886b4ea9371d94e0571f4852f6d16fed1f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
@@ -25,6 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/openldap/Default
   TITLE:=LDAP implementation
   URL:=http://www.openldap.org/
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 endef
 
 define Package/libopenldap
@@ -63,7 +64,7 @@ define Package/openldap-server
   $(call Package/openldap/Default)
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenldap +libdb47
+  DEPENDS:=+libopenldap
   TITLE+= (server)
 endef
 
@@ -73,6 +74,10 @@ define Package/openldap-server/description
        This package contains server programs required to provide LDAP services.
 endef
 
+define Package/openldap-server/conffiles
+/etc/openldap/slapd.conf
+endef
+
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
@@ -90,8 +95,12 @@ CONFIGURE_ARGS += \
        --with-yielding_select="yes" \
        --without-cyrus-sasl \
        --without-threads \
-       --without-tls 
-
+       --without-tls \
+       --enable-null \
+       --disable-bdb \
+       --disable-hdb \
+       --disable-monitor \
+       --disable-relay
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -102,16 +111,16 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libopenldap/install
        $(INSTALL_DIR) $(1)/etc/openldap
-       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
 endef
        
 define Package/openldap-utils/install
@@ -122,8 +131,10 @@ endef
 define Package/openldap-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ldap.init $(1)/etc/init.d/ldap
+       $(INSTALL_DIR) $(1)/etc/openldap/ldif
        $(INSTALL_DIR) $(1)/etc/openldap/schema
-       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/sbin
        # OpenLDAP installs slapd into libexecdir, not sbindir:
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/