remove UninstallDev
[openwrt/svn-archive/archive.git] / libs / openldap / Makefile
index 8702315f64f0c49cefddfe227d6b10e6515816fb..ab0f53e4a57902b70ebff99f02d1c1b1895a49e9 100644 (file)
@@ -18,7 +18,6 @@ PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
        ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
        ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
 PKG_MD5SUM:=6c4c72a1336aa45b463e738034c078d6
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,9 +26,6 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/openldap/Default
   TITLE:=LDAP implementation
-  DESCRIPTION:=\
-    OpenLDAP Software is an open source implementation of the \\\
-    Lightweight Directory Access Protocol (LDAP).
   URL:=http://www.openldap.org/
 endef
 
@@ -39,9 +35,13 @@ define Package/libopenldap
   CATEGORY:=Libraries
   DEPENDS:=+libopenssl +libsasl2
   TITLE+= (libraries)
-  DESCRIPTION+=\\\
-    \\\
-    This package contains the shared LDAP client libraries, needed by other programs.
+endef
+
+define Package/libopenldap/description
+=
+       OpenLDAP Software is an open source implementation of the 
+       Lightweight Directory Access Protocol (LDAP).   
+       This package contains the shared LDAP client libraries, needed by other programs.
 endef
 
 define Package/libopenldap/conffiles
@@ -54,12 +54,16 @@ define Package/openldap-utils
   CATEGORY:=Utilities
   DEPENDS:=+libopenldap
   TITLE+= (utilities)
-  DESCRIPTION+=\\\
-    \\\
-    This package contains client programs required to access LDAP servers.
 endef
 
-PKG_CONFIGURE_OPTIONS = \
+define Package/openldap-utils/description
+=
+       OpenLDAP Software is an open source implementation of the 
+       Lightweight Directory Access Protocol (LDAP).   
+       This package contains client programs required to access LDAP servers.
+endef
+
+CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-debug \
@@ -73,103 +77,37 @@ PKG_CONFIGURE_OPTIONS = \
        --with-threads \
        --with-tls \
        --with-yielding_select="yes" \
+       --without-cyrus-sasl \
+       --without-threads \
+       --without-tls 
 
-define Build/Configure
-endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       -$(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               distclean
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               ./configure \
-                       --target=$(GNU_HOST_NAME) \
-                       --host=$(GNU_HOST_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       $(PKG_CONFIGURE_OPTIONS) \
-                       --without-cyrus-sasl \
-                       --without-threads \
-                       --without-tls \
-       );
-       $(MAKE) -C $(PKG_BUILD_DIR) depend 
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblunicode
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber clean
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil clean
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
-               ac_cv_func_memcmp_clean="yes" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       $(PKG_CONFIGURE_OPTIONS) \
-       );
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               HOSTCC="$(HOSTCC)" \
+               depend all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-       
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/{lber,ldap}*.h \
-               $(STAGING_DIR)/usr/lib/lib{lber,ldap}*.{a,so*}
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libopenldap/install
-       install -d -m0755 $(1)/etc/openldap
+       $(INSTALL_DIR) $(1)/etc/openldap
        $(CP) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/share/openldap
+       $(INSTALL_DIR) $(1)/usr/share/openldap
        $(CP) $(PKG_INSTALL_DIR)/usr/share/openldap/* $(1)/usr/share/openldap/
 endef
        
 define Package/openldap-utils/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libopenldap))