Add libtool fixup to libusb.
[openwrt/svn-archive/archive.git] / libs / openldap / Makefile
index ab0f53e4a57902b70ebff99f02d1c1b1895a49e9..c491f3befec8d8b0f69182b7809ee94a3003bec0 100644 (file)
@@ -19,8 +19,7 @@ PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
        ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
 PKG_MD5SUM:=6c4c72a1336aa45b463e738034c078d6
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -63,6 +62,8 @@ define Package/openldap-utils/description
        This package contains client programs required to access LDAP servers.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \