[packages] polarssl: fix parallel build
[openwrt/svn-archive/archive.git] / libs / polarssl / Makefile
index a00a0b58240f1375aab75d16b13718fade5fd4e3..ffd5aea73198e425b993064ea6aaaeb59def7e3c 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006-2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=polarssl
 PKG_VERSION:=0.12.1
 
 PKG_NAME:=polarssl
 PKG_VERSION:=0.12.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=http://polarssl.org/code/releases/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=http://polarssl.org/code/releases/
@@ -24,8 +24,8 @@ define Package/polarssl/Default
 endef
 
 define Package/libpolarssl/Default/description
 endef
 
 define Package/libpolarssl/Default/description
- The aim of the PolarSSL project is to provide a quality, open-source 
- cryptographic library written in C and targeted at embedded systems.
+The aim of the PolarSSL project is to provide a quality, open-source
+cryptographic library written in C and targeted at embedded systems.
 endef
 
 define Package/libpolarssl
 endef
 
 define Package/libpolarssl
@@ -43,36 +43,29 @@ $(call Package/polarssl/Default)
   TITLE+= (programs)
 endef
 
   TITLE+= (programs)
 endef
 
+PKG_INSTALL:=1
+
 define Build/Configure
 endef
 
 TARGET_CFLAGS += $(FPIC)
 define Build/Configure
 endef
 
 TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               OFLAGS="$(TARGET_CFLAGS)" \
-               all
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)/usr" \
-               install
-endef
+MAKE_FLAGS += OFLAGS="$(TARGET_CFLAGS)"
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/polarssl $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/include/polarssl $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpolarssl.{a,so} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/lib/libpolarssl.{a,so} $(1)/usr/lib/
 endef
 
 define Package/libpolarssl/install
        $(INSTALL_DIR) $(1)/usr/lib
 endef
 
 define Package/libpolarssl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libpolarssl.so $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/libpolarssl.so $(1)/usr/lib/
 endef
 
 define Package/polarssl-progs/install
        $(INSTALL_DIR) $(1)/usr/bin
 endef
 
 define Package/polarssl-progs/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/polarssl_* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/polarssl_* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libpolarssl))
 endef
 
 $(eval $(call BuildPackage,libpolarssl))