make libmad depending on CONFIG_BUILD_PATENTED
[openwrt/svn-archive/archive.git] / libs / popt / Makefile
index 5e977156e07020f4eec9366a23b1d92c8be8e172..3a5b7542d818d2f8297f3ac7f6501af538a4be4f 100644 (file)
@@ -1,58 +1,56 @@
-# $Id: Makefile 3843 2006-05-30 18:55:52Z nbd $
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=popt
 PKG_VERSION:=1.7
-PKG_RELEASE:=4
-PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
+PKG_RELEASE:=5
 
-PKG_SOURCE_URL:=ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS += $(FPIC)
 
 define Package/libpopt
-SECTION:=libs
-CATEGORY:=Libraries
-TITLE:=A command line option parsing library
-DESCRIPTION:=A command line option parsing library
-URL:=ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A command line option parsing library
+  URL:=http://rpm5.org/files/popt/
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared --enable-static)
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+       )
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libpopt/install
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.so.* $(1)/usr/lib/
 endef
 
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(STAGING_DIR)/usr/lib/
-       touch $(STAGING_DIR)/usr/lib/libpopt.so
-endef
-       
-define Build/UninstallDev
-       rm -rf \
-         $(STAGING_DIR)/usr/include/popt.h \
-         $(STAGING_DIR)/usr/lib/libpopt.{a,so*}
-endef
+$(eval $(call RequireCommand,xgettext, \
+       $(PKG_NAME) requires the GNU gettext development package installed on the local system to build. \
+))
 
 $(eval $(call BuildPackage,libpopt))
+