[packages] Require* calls must now be placed before BuildPackage calls
[openwrt/svn-archive/archive.git] / libs / popt / Makefile
index 27ad255..f4ae787 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -51,8 +51,9 @@ define Package/libpopt/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call BuildPackage,libpopt))
-
 $(eval $(call RequireCommand,xgettext, \
        $(PKG_NAME) requires the GNU gettext development package installed on the local system to build. \
 ))
+
+$(eval $(call BuildPackage,libpopt))
+