update to the latest 7.4.x version of postgresql.. security and other fun stuff
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index 78cc54256941ddc072d6f754265c4eb293a07688..3bb14c5f3bfdeb4f6bf07680cfcc8a3db46bac11 100644 (file)
@@ -9,17 +9,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=7.4.9
+PKG_VERSION:=7.4.14
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
-       ftp://ftp3.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/ \
-       ftp://ftp.br.postgresql.org/pub/PostgreSQL/source/v$(PKG_VERSION)/ \
-       ftp://ftp.au.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/ \
-       ftp://ftp.tw.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/
-PKG_MD5SUM:=d7cf0f0a0e1dda19268f55cb1e124c77
+       ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
+       ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
+PKG_MD5SUM:=2e0e82552f8463343df5d89348356481
 PKG_CAT:=bzcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -36,9 +34,9 @@ define Package/libpq
 endef
 
 define Package/pgsql-cli
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libpq
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libpq
   TITLE:=Command Line Interface (CLI) to PostgreSQL databases
   DESCRIPTION:=Command Line Interface (CLI) to PostgreSQL databases.
   URL:=http://www.postgresql.org/