Fix postgresql installation when already compiled
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index 804c510215d869d498b69716c2121e934bdb69b5..5d60831e7ba38600f677e025d362859451607a3a 100644 (file)
@@ -9,15 +9,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.2.5
+PKG_VERSION:=8.3.0
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
-       ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
+       http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp8.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=bb1cd309ea72f070cb964736f5755847
+PKG_MD5SUM:=53d6816eac7442f9bc8103439ebee22e
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
@@ -155,6 +158,8 @@ define Build/Configure
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
        $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile
+       # note: unclear if this is needed yet, commenting out for the moment
+       #$(SED) 's@US/Eastern@America/New_York@' $(PKG_BUILD_DIR)/src/timezone/Makefile
 endef
 
 define Build/Compile
@@ -170,7 +175,7 @@ endef
 
 define Package/pgsql-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/psql $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psql $(1)/usr/bin/
 endef
 
 define Package/pgsql-server/install
@@ -182,18 +187,25 @@ define Package/pgsql-server/install
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/postgres \
                $(PKG_INSTALL_DIR)/usr/bin/dropdb \
+               $(PKG_INSTALL_DIR)/usr/bin/clusterdb \
                $(PKG_INSTALL_DIR)/usr/bin/createdb \
+               $(PKG_INSTALL_DIR)/usr/bin/createlang \
                $(PKG_INSTALL_DIR)/usr/bin/createuser \
+               $(PKG_INSTALL_DIR)/usr/bin/droplang \
                $(PKG_INSTALL_DIR)/usr/bin/dropuser \
                $(PKG_INSTALL_DIR)/usr/bin/initdb \
+               $(PKG_INSTALL_DIR)/usr/bin/ipcclean \
                $(PKG_INSTALL_DIR)/usr/bin/pg_config \
                $(PKG_INSTALL_DIR)/usr/bin/pg_controldata \
                $(PKG_INSTALL_DIR)/usr/bin/pg_ctl \
                $(PKG_INSTALL_DIR)/usr/bin/pg_dump \
                $(PKG_INSTALL_DIR)/usr/bin/pg_dumpall \
                $(PKG_INSTALL_DIR)/usr/bin/pg_restore \
+               $(PKG_INSTALL_DIR)/usr/bin/pg_resetxlog \
+               $(PKG_INSTALL_DIR)/usr/bin/reindexdb \
                $(PKG_INSTALL_DIR)/usr/bin/vacuumdb \
                $(1)/usr/bin
+       ln -sf postgres $(1)/usr/bin/postmaster
 
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql
 
@@ -252,7 +264,7 @@ endef
 
 define Build/InstallDev
        mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config.host $(1)/usr/bin/pg_config
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config.host $(1)/usr/bin/pg_config
        mkdir -p $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libpq $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(1)/usr/include/
@@ -265,19 +277,6 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/src/timezone/zic.host $(1)/usr/bin/zic
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/pg_config \
-               $(STAGING_DIR)/usr/include/libpq \
-               $(STAGING_DIR)/usr/include/libpq-fe.h \
-               $(STAGING_DIR)/usr/include/pg_config.h \
-               $(STAGING_DIR)/usr/include/postgres_ext.h \
-               $(STAGING_DIR)/usr/include/postgresql \
-               $(STAGING_DIR)/usr/lib/libpq.{a,so*} \
-               $(STAGING_DIR)/usr/bin/ecpg \
-               $(STAGING_DIR)/usr/bin/zic
-endef
-
 $(eval $(call BuildPackage,libpq))
 $(eval $(call BuildPackage,pgsql-cli))
 $(eval $(call BuildPackage,pgsql-server))