[package] update postgresql to 9.0.0 (#7999)
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index 00240d77f05f1a20297632f5a8c82fc763b47506..7ef6aa78a06009301263c63b0143812fcf3c8d43 100644 (file)
@@ -1,37 +1,35 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.2.5
+PKG_VERSION:=9.0.0
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
-       ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
+       http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp8.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=bb1cd309ea72f070cb964736f5755847
-PKG_CAT:=bzcat
-
-PKG_BUILD_DEPENDS:=libnotimpl
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=14c2122cc322e69ab2ab702ed7714bbe
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libpq
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib +libreadline +libncurses
+  DEPENDS:=+zlib +libreadline +libncurses +coreutils-su
   TITLE:=PostgreSQL client library
   URL:=http://www.postgresql.org/
+  SUBMENU:=database
 endef
 
 define Package/libpq/description
@@ -44,6 +42,7 @@ define Package/pgsql-cli
   DEPENDS:=+libpq
   TITLE:=Command Line Interface (CLI) to PostgreSQL databases
   URL:=http://www.postgresql.org/
+  SUBMENU:=database
 endef
 
 define Package/pgsql-cli/description
@@ -56,6 +55,7 @@ define Package/pgsql-server
   DEPENDS:=+libpq
   TITLE:=PostgreSQL databases Server
   URL:=http://www.postgresql.org/
+  SUBMENU:=database
 endef
 
 define Package/pgsql-server/description
@@ -97,12 +97,13 @@ define Build/Configure
                        --without-tk \
                        --with-zlib="yes" \
                        --enable-depend \
+                       --with-system-timezone=/tmp \
        );
        $(MAKE) -C $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc CC="$(HOSTCC)" CFLAGS+="-I../../libpq"
        mv $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg \
                $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg.host
        $(MAKE) -C $(PKG_BUILD_DIR)/src/timezone CC="$(HOSTCC)"
-       mv $(PKG_BUILD_DIR)/src/timezone/zic $(PKG_BUILD_DIR)/src/timezone/zic.host
+       mv $(PKG_BUILD_DIR)/src/timezone/zic $(STAGING_DIR)/host/bin/zic
        $(MAKE) -C $(PKG_BUILD_DIR)/src/bin/pg_config CC="$(HOSTCC)"
        mv $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config \
                $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config.host
@@ -113,7 +114,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="$$$$CPPFLAGS $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBS="-lnotimpl" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
@@ -150,15 +150,20 @@ define Build/Configure
                        --without-tk \
                        --with-zlib="yes" \
                        --enable-depend \
+                       $(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
-       $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
-       $(MAKE) -C "$(PKG_BUILD_DIR)" \
+       $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               all
+       $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
 endef
 
 define Package/libpq/install
@@ -168,7 +173,7 @@ endef
 
 define Package/pgsql-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/psql $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psql $(1)/usr/bin/
 endef
 
 define Package/pgsql-server/install
@@ -177,103 +182,61 @@ define Package/pgsql-server/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/bin/postgres \
-               $(PKG_INSTALL_DIR)/usr/bin/dropdb \
-               $(PKG_INSTALL_DIR)/usr/bin/createdb \
-               $(PKG_INSTALL_DIR)/usr/bin/createuser \
-               $(PKG_INSTALL_DIR)/usr/bin/dropuser \
-               $(PKG_INSTALL_DIR)/usr/bin/initdb \
-               $(PKG_INSTALL_DIR)/usr/bin/pg_config \
-               $(PKG_INSTALL_DIR)/usr/bin/pg_controldata \
-               $(PKG_INSTALL_DIR)/usr/bin/pg_ctl \
-               $(PKG_INSTALL_DIR)/usr/bin/pg_dump \
-               $(PKG_INSTALL_DIR)/usr/bin/pg_dumpall \
-               $(PKG_INSTALL_DIR)/usr/bin/pg_restore \
-               $(PKG_INSTALL_DIR)/usr/bin/vacuumdb \
-               $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+       ln -sf postgres $(1)/usr/bin/postmaster
 
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql
 
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/postgres.bki \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/postgres.description \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/conversion_create.sql \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/information_schema.sql \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/pg_hba.conf.sample \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/pg_ident.conf.sample \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/pg_service.conf.sample \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/postgresql.conf.sample \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/sql_features.txt \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/postgres.shdescription \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/psqlrc.sample \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/recovery.conf.sample \
-               $(PKG_INSTALL_DIR)/usr/share/postgresql/system_views.sql \
+       $(CP) -r $(PKG_INSTALL_DIR)/usr/share/postgresql/* \
                $(1)/usr/share/postgresql
 
-               $(INSTALL_DATA) ./files/postgresql.config $(1)/etc/config/postgresql
-
-               $(CP) -r \
-                       $(PKG_INSTALL_DIR)/usr/share/postgresql/timezone \
-                       $(PKG_INSTALL_DIR)/usr/share/postgresql/timezonesets \
-                       $(1)/usr/share/postgresql
+       $(INSTALL_DATA) ./files/postgresql.config $(1)/etc/config/postgresql
 
-               $(CP) -r \
-                       $(PKG_INSTALL_DIR)/usr/lib/postgresql \
-                       $(1)/usr/lib
+       $(CP) -r \
+               $(PKG_INSTALL_DIR)/usr/lib/postgresql \
+               $(1)/usr/lib
 endef
 
 define Package/pgsql-server/postinst
 #!/bin/sh
 grep -q '^postgres:' /etc/passwd && exit 0
-
-if [ -e /bin/addgroup ]; then
-  /bin/addgroup postgres
-  RG=$$?
-
-  if [ -e /bin/adduser ]; then
-    /bin/adduser -h /tmp -H -g 'PostgreSQL administrator' -s /bin/ash -D -H -G postgres postgres
-       RU=$$?
-  fi
-fi
-
-if [ -z "$${RG}" -o -z "$${RU}" ]; then
-  echo "Could not find user utils, you will need to create the postgres user by hand"
-  exit 
+group=$$(grep '^postgres:' /etc/group | cut -f3 -d:)
+if [ -z "$${group}" ] ; then
+       group=1000
+       tst=$$(cat /etc/group | grep ":$${group}:")
+       while [ -n "$${tst}" ] ; do
+               group=$$(($${group}+1))
+               tst=$$(cat /etc/group | grep ":$${group}:")
+       done
+       echo "postgres:x:$${group}:" >>/etc/group
 fi
 
-if [ "$${RG}" != "0" -o "$${RU}" != "0" ]; then
-  echo "Failed to created postgres user"
-  exit 1
+user=$$(cat /etc/passwd | grep "^postgres:")
+if [ -z "$${user}" ] ; then
+       num="$${group}"
+       tst=$$(cat /etc/passwd | grep ":.*:$${num}:")
+       while [ -n "$${tst}" ] ; do
+               num=$$(($${num}+1))
+               tst=$$(cat /etc/passwd | grep ":.*:$${num}:")
+       done
+       echo "postgres:*:$${num}:$${group}:PostgreSQL administrator:/tmp:/bin/ash" >>/etc/passwd
 fi
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config.host $(1)/usr/bin/pg_config
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config.host $(1)/usr/bin/pg_config
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libpq $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_manual.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/postgresql $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpq.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg.host $(1)/usr/bin/ecpg
-       $(CP) $(PKG_BUILD_DIR)/src/timezone/zic.host $(1)/usr/bin/zic
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/pg_config \
-               $(STAGING_DIR)/usr/include/libpq \
-               $(STAGING_DIR)/usr/include/libpq-fe.h \
-               $(STAGING_DIR)/usr/include/pg_config.h \
-               $(STAGING_DIR)/usr/include/postgres_ext.h \
-               $(STAGING_DIR)/usr/include/postgresql \
-               $(STAGING_DIR)/usr/lib/libpq.{a,so*} \
-               $(STAGING_DIR)/usr/bin/ecpg \
-               $(STAGING_DIR)/usr/bin/zic
+       $(CP) $(STAGING_DIR)/host/bin/zic $(1)/usr/bin/zic
 endef
 
 $(eval $(call BuildPackage,libpq))