phidget21: add missing dependency
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index a534612795ee7619ae58a98ad3fae5e3e336f75d..a234fafaeebb2484daad75fa910aa351e579c84d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=9.0.0
-PKG_RELEASE:=1
+PKG_VERSION:=9.0.1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
-       http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
-       http://ftp8.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
-       http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=14c2122cc322e69ab2ab702ed7714bbe
+PKG_MD5SUM:=57ba57e43cfe29e16dacbf5789be98d1
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -26,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libpq
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib +libreadline +libncurses +coreutils-su
+  DEPENDS:=+zlib +libreadline +libpthread +libncurses +coreutils-su
   TITLE:=PostgreSQL client library
   URL:=http://www.postgresql.org/
   SUBMENU:=database
@@ -79,7 +77,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --enable-static \
                        --disable-integer-datetimes \
@@ -159,6 +156,9 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+# because PROFILE means something else in the project Makefile
+unexport PROFILE
+
 define Build/Compile
        $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -199,6 +199,10 @@ define Package/pgsql-server/install
                $(1)/usr/lib
 endef
 
+define Package/pgsql-server/conffiles
+/etc/config/postgresql
+endef
+
 define Package/pgsql-server/postinst
 #!/bin/sh
 grep -q '^postgres:' /etc/passwd && exit 0