[packages] libnfnetlink: update to v0.40, install dev pkgconfig file
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index 88692579a06901a85f6758f958e85ec784901dc5..aa13984505ced38306a8f2cea8af405240fb9ae0 100644 (file)
@@ -9,20 +9,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.2.5
+PKG_VERSION:=8.3.3
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
-       ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
+       http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp8.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=bb1cd309ea72f070cb964736f5755847
+PKG_MD5SUM:=0ae4bd9620e84d3e08dcf923808d14d0
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libpq
@@ -152,11 +152,16 @@ define Build/Configure
                        --without-tk \
                        --with-zlib="yes" \
                        --enable-depend \
+                       $(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
        $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile
+       # note: unclear if this is needed yet, commenting out for the moment
+       #$(SED) 's@US/Eastern@America/New_York@' $(PKG_BUILD_DIR)/src/timezone/Makefile
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -182,18 +187,25 @@ define Package/pgsql-server/install
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/postgres \
                $(PKG_INSTALL_DIR)/usr/bin/dropdb \
+               $(PKG_INSTALL_DIR)/usr/bin/clusterdb \
                $(PKG_INSTALL_DIR)/usr/bin/createdb \
+               $(PKG_INSTALL_DIR)/usr/bin/createlang \
                $(PKG_INSTALL_DIR)/usr/bin/createuser \
+               $(PKG_INSTALL_DIR)/usr/bin/droplang \
                $(PKG_INSTALL_DIR)/usr/bin/dropuser \
                $(PKG_INSTALL_DIR)/usr/bin/initdb \
+               $(PKG_INSTALL_DIR)/usr/bin/ipcclean \
                $(PKG_INSTALL_DIR)/usr/bin/pg_config \
                $(PKG_INSTALL_DIR)/usr/bin/pg_controldata \
                $(PKG_INSTALL_DIR)/usr/bin/pg_ctl \
                $(PKG_INSTALL_DIR)/usr/bin/pg_dump \
                $(PKG_INSTALL_DIR)/usr/bin/pg_dumpall \
                $(PKG_INSTALL_DIR)/usr/bin/pg_restore \
+               $(PKG_INSTALL_DIR)/usr/bin/pg_resetxlog \
+               $(PKG_INSTALL_DIR)/usr/bin/reindexdb \
                $(PKG_INSTALL_DIR)/usr/bin/vacuumdb \
                $(1)/usr/bin
+       ln -sf postgres $(1)/usr/bin/postmaster
 
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql
 
@@ -211,6 +223,7 @@ define Package/pgsql-server/install
                $(PKG_INSTALL_DIR)/usr/share/postgresql/psqlrc.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/recovery.conf.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/system_views.sql \
+               $(PKG_INSTALL_DIR)/usr/share/postgresql/snowball_create.sql \
                $(1)/usr/share/postgresql
 
                $(INSTALL_DATA) ./files/postgresql.config $(1)/etc/config/postgresql
@@ -265,19 +278,6 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/src/timezone/zic.host $(1)/usr/bin/zic
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/pg_config \
-               $(STAGING_DIR)/usr/include/libpq \
-               $(STAGING_DIR)/usr/include/libpq-fe.h \
-               $(STAGING_DIR)/usr/include/pg_config.h \
-               $(STAGING_DIR)/usr/include/postgres_ext.h \
-               $(STAGING_DIR)/usr/include/postgresql \
-               $(STAGING_DIR)/usr/lib/libpq.{a,so*} \
-               $(STAGING_DIR)/usr/bin/ecpg \
-               $(STAGING_DIR)/usr/bin/zic
-endef
-
 $(eval $(call BuildPackage,libpq))
 $(eval $(call BuildPackage,pgsql-cli))
 $(eval $(call BuildPackage,pgsql-server))