[packages] libnfnetlink: update to v0.40, install dev pkgconfig file
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index 8972651a21a1da9c5a0ca4c8b66b617012bbd4d6..aa13984505ced38306a8f2cea8af405240fb9ae0 100644 (file)
@@ -152,6 +152,7 @@ define Build/Configure
                        --without-tk \
                        --with-zlib="yes" \
                        --enable-depend \
+                       $(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
        $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile
@@ -159,6 +160,8 @@ define Build/Configure
        #$(SED) 's@US/Eastern@America/New_York@' $(PKG_BUILD_DIR)/src/timezone/Makefile
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \