bump postgresql to newer version, thanks KanjiMonster, #3520
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index b59d9f95c0b7f03ca0da2cc6758de9e89ce69102..d3b7756fbde7e1b079395a20e30c5c451bc6d837 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.3.0
+PKG_VERSION:=8.3.1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -20,7 +20,7 @@ PKG_SOURCE_URL:=\
        http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=53d6816eac7442f9bc8103439ebee22e
+PKG_MD5SUM:=a5e0ed6a85b450dc217ec71da93243a7
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
@@ -205,8 +205,7 @@ define Package/pgsql-server/install
                $(PKG_INSTALL_DIR)/usr/bin/reindexdb \
                $(PKG_INSTALL_DIR)/usr/bin/vacuumdb \
                $(1)/usr/bin
-
-       $(LN) -s postgres $(1)/usr/bin/postmaster
+       ln -sf postgres $(1)/usr/bin/postmaster
 
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql
 
@@ -224,6 +223,7 @@ define Package/pgsql-server/install
                $(PKG_INSTALL_DIR)/usr/share/postgresql/psqlrc.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/recovery.conf.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/system_views.sql \
+               $(PKG_INSTALL_DIR)/usr/share/postgresql/snowball_create.sql \
                $(1)/usr/share/postgresql
 
                $(INSTALL_DATA) ./files/postgresql.config $(1)/etc/config/postgresql