postgresql: update to version 9.0.1
[openwrt/svn-archive/archive.git] / libs / postgresql / patches / 200-ranlib.patch
index 7029b099548afa0c099284a3a5ea5444e6793723..1b68b8378bdb706974c70122e992800b7f118b3e 100644 (file)
@@ -1,10 +1,10 @@
---- postgresql.old/src/port/Makefile   Sun Oct 15 00:09:57 2006
-+++ postgresql.dev/src/port/Makefile   Sun Oct 15 00:10:05 2006
-@@ -21,6 +21,7 @@
+--- a/src/port/Makefile
++++ b/src/port/Makefile
+@@ -53,6 +53,7 @@ uninstall:
  
- libpgport.a: $(LIBOBJS)
+ libpgport.a: $(OBJS)
        $(AR) $(AROPT) $@ $^
 +      $(RANLIB) libpgport.a
  
+ # thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
  thread.o: thread.c
-       $(CC) $(CFLAGS) $(CPPFLAGS) $(THREAD_CPPFLAGS) -c $<